No announcement yet.

Asian Language Fonts

  • Filter
  • Time
  • Show
Clear All
new posts

  • Asian Language Fonts

    I am trying to put together a menu which will have Chinese, Korean and Japanese however when I enter the information, it appears as ???????
    It should be noted that I am not typing in these characters but cutting and pasting from a word document. Is there an issue with this or is there a special way I need to handle?

    Example "オンライン" comes over as "?????"

  • #2
    If you want to use a non-Western language, then you have to make sure that you are using the proper encoding, font script, and computer settings.
    1. Region and Language

      If you want to see, for example, Japanese glyphs in the Autorun MAX! development environment, then you have to make sure that the setting for the language for non-Unicode programs is also set to Japanese. You find this setting in Region and Language, in the Control Panel.
      Click image for larger version

Name:	SCRN-2014-04-15-02.png
Views:	1
Size:	26.9 KB
ID:	284185
    2. Font script

      If you want to show texts in the AutoPlay application which don't use Western glyphs, then you need also to change the Script setting to the proper option. Depending on the font you selected, you will see options for Japanese, Hangul, Chinese, Hebrew, Arabic, Greek, Cyrillic, etc. If the font you selected does not show the option you need, then you have to install / select a font which offers support for these letters.
      Click image for larger version

Name:	SCRN-2014-04-15-03.png
Views:	1
Size:	119.3 KB
ID:	284186
    3. Encoding

      As mentioned in the first item, Autorun MAX! is not Unicode compatible, so you cannot simply copy and paste texts. The source text may use Unicode encoding, while Autorun MAX! can process only ANSI encoding. If you want to use Japanese text, you certainly can do so (as the screen capture above shows), but instead of using Unicode encoded text, it needs to use the Shift-JIS (Windows-932) encoding.

    Once you have the language showing as you want, make the changes in the Region and Language settings to enable the processing of the next language, and repeat the procedure.



    • #3
      non -western fonts still causing problems

      Thanks for this information. I've done what you have suggested, however I do not have Arial Unicode MS as your sample shows. I was able to type in Japanese but it still converted over to question marks.

      I attempted with several different fonts with the same reaction.
      Attached Files


      • #4
        You have to make sure that you are using ANSI encoding for the text. It won't work if you are entering Unicode.
        If you are unsure what encoding you are using, copy the string into a text file and attach it here.