No announcement yet.

RAM drives and AMS

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by sim View Post

    Any bugs please screenshot them so me and cyber know whats going on.
    screenshots from the test.
    Debug1.png is when the error message appears
    Debug2.png is after "OK" on the error message
    Click image for larger version

Name:	debug.PNG
Views:	1
Size:	16.0 KB
ID:	283026

    Click image for larger version

Name:	error.png
Views:	1
Size:	9.6 KB
ID:	283025

    Click image for larger version

Name:	debug2.PNG
Views:	1
Size:	20.9 KB
ID:	283024


    @sim, @cybergraph
    I tried the core64.exe as well and it came back with

    Click image for larger version

Name:	cmd.PNG
Views:	1
Size:	26.1 KB
ID:	283027
    Last edited by MadDogDean; 12-16-2010, 05:58 PM. Reason: update


    • #62
      many thanks for your report.

      I think the error reported by MadDogSean is generated by this:

      function RAMDrive.Mount()
      	Shell.Execute(RAMDrive.Driver, "open", "on", [COLOR="red"]"AutoPlay\\Docs\\"[/COLOR], SW_HIDE, true);
      	if Folder.DoesExist("R:\\TEMP") then
      		return true;
      		return false;
      Because the program needs to pick up the drivers inside the wow64 folder, it should be:

      Shell.Execute(RAMDrive.Driver, "open", "on", [COLOR="blue"]"AutoPlay\\Docs\\wow64\\"[/COLOR], SW_HIDE, true);
      otherwise core.exe, even if it is started in the correct folder (wow64) will read the drivers in the upper folder ("AutoPlay\\Docs\\").

      By this it is necessary to create 2 different Shell.Execute calls pointing to respective folders.
      We are slowly invading your planet to teach lazy humans to read the user manual.
      But don't be scared: we are here to help.


      • #63
        Yes that could be the problem MadDog could you redownload the app and then chage the file path it already points to core64 if your on a 64 bit os see the function Is64 I think file that could be the problem its trying to run the program in the other program where it could be getting the wrong details, I will add a new table called RAMDrive.Path to the one I am working on thanks for the bug reports and I should release one mind day UK time or around then as thats when I get up lol.

        core64.exe is the 64 bit version what is your os ? Window 7 64 bit?

        #bug commandline plugin added for no reason 01
        #bug file path 02
        #bug core64 mismatch (Unknown) 03

        These errors are loged thanks
        Last edited by sim; 12-16-2010, 07:49 PM.


        • #64
          Ok looks Like I am going to have to install windows 7 x64 along side windows 7 32 last time I tried this with 7 I had problems and just droped back to one OS so wish me luck will do this first thing when i get up tomorrow/taday


          • #65
            Not dead

            After New year I will try take work on this back up I just been helping out a few support groups and lost the track of
            other things but I have not forgot this, I have taken the bump on my laptop to full 64 bit no V-Box anymore so I should
            see any 64 bit bugs off the bat.

            Hope you all had a nice xmas and hope you have a good new year.


            • #66
              Believe it or not I never let this be but the ramdisk I used what worked via command line I can't find anymore there for can't get it to work, I not sure if anyone else had any work on this but sadly I now do believe it's dead for now, loading a image file is easy and even easier on windows 10 but creating the virtual drive to take it's space from RAM is what we are stuck on.
              Last edited by kingzooly; 10-31-2019, 10:03 AM.
              Plugins or Sources MokoX
              BunnyHop Here