No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • Crashing!!

    AMS4 keeps crashing on me. The following messages come up:
    1) "Error:Access violation at 0x8317DBF8 (tried to read from 0x8317DBF8) program terminated"

    This error occurs even when I have put the project onto CD.
    It then comes up with "illegal operation" in exporer and terminates the programme.

    2) The other error reads: "Access violation at address 031B22D1 in module 'PTXSCP.OCX'. Read of address FFFFFFFF.

    This happens when I am in design mode.

    The project is fairly large consisting of over 100 pages, converted from version 3 of AMS. I have AMS3 still installed on the PC (because AMS4 is not behaving).
    Using Win 98 SE
    PIII 450
    256MB RAM
    ATI Rage 128 PRO (32MB)
    Logitech Cordless optical mouse

    I had no crashes with the Beta versions.
    Please help.

  • #2
    Re: Crashing!!

    Hi Carlos - what exactly are you doing at design time when the crash occurs?

    Can yu give us a step-by-step so you can be assisted further on this problem.

    = Derek
    ["All glory comes from daring to begin" - fortune cookie]


    • #3
      Re: Crashing!!

      Hi Derek,

      I had just converted the AMS3 file to AMS4. I was moving and resizing many hot spot objects. I noticed that it was very slow at unlocking the objects when I selected them all. And also once I selected them again and asked it to lock, it was almost dead.
      Anyway I then did a preview of the entire project. It crashed then, but not immediately. It also crashed when I built the project and ran it. AMS4 was still open at the time. It always comes back with an 'illegal operation in explorer and shuts the programme down and the machine becomes unstable. It reports those errors I have listed in my message as well.
      I will take note of exactly what I was doing when it happens again and let you know. Thanks.


      • #4
        Re: Crashing!!

        Latest on crashing:
        Loaded the project. Did some changes to hotspot object goto links, nothing heavy. Minimized AMS4 and worked on my graphics programme. Other programmes open at the time: Windows Explorer, MS Word, graphics programme. While working in my graphics program ( Ulead's Photo Impact 7), I experienced the following message again:
        "Error:Access violation at 0x8317DBF8 (tried to read from 0x8317DBF8) program terminated"
        Once you close this window it comes up a few times again. It then comes up with an "illegal Operation" and refers to Explorer. Have to shutdown to get rid of the message coming up periodically. System becomes unstable.

        Can we have AMS3 and 4 installed on the same system?


        • #5
          Re: Crashing!!

          We're working hard on this problem. (Actually, we may have already solved it...we'll release a patch as soon as we're sure.)

          In the mean time, you should be able to eliminate the crashing by setting your Undo/Redo levels to "0" in the AutoPlay preferences. (Effectively turning off undo/redo.)
          --[[ Indigo Rose Software Developer ]]


          • #6
            Re: Crashing!!

            Thanks for the effort and speedy response.

            Don't want to sound corny, but that is what sets you guys appart from the rest.

            I have just received the "beta patch" from Darryl Hnatiuk and will try it out now.

            Thanks again!


            • #7
              Re: Crashing!!

              You're welcome, Carlos.

              Just a note to other users: the beta patch is currently only being distributed to some of our users who have encountered this bug so they can assist in testing. We'll release an official patch as soon as possible.
              --[[ Indigo Rose Software Developer ]]


              • #8
                Re: Crashing!!

                Yes I am also having the same program with It crashing, with this happening
                Error:Access violation at 0x8317DBF8 (tried to read from 0x8317DBF8) program terminated

                especially when loading objects and also Previewing projects, It seems to crash and bum out Explorer

                Running 1.2Ghz machine w98se 128Mb ram etc..


                • #9
                  Re: Crashing!!

                  My last crash, no error codes given, was after opening IE version 6.0, went back into AMS 4.0, and simply moved my mouse across the icons within 4.0 - bam boom CRASH! Everything disappeared. I reopened to my previous save (glad I did that).

                  800mhz 98se 256mb ram blah blah blah


                  • #10
                    Re: Crashing!!

                    May be it is just a coincidence! I have also imported the project from AM3 and after last crush lost the project completely and had to build from scratch in AM4 but since i have done this, I did not get the crush vith the Violation message.Well AM4 still dissapears sometime when i hit the build or prewiev button but the programm is still there when I go into it again(provided I have saved my work before)


                    • #11
                      Re: Crashing!!

                      I'm also having the same problem. There seems to be some problem with IE and APMS4.

                      If I use (design mode) Auto Play Media Studio then IE (6) becomes unstable. After a re-boot IE runs OK if APMS has not been run. I also get the lockups in APMS at random moments. I have reset my undo levels to zero.

                      I have reported all this to support but so far (disappointingly) I have not had a response. (Maybe it's time zones)

                      Otherwise - it's a great product, which makes it even more annoying.


                      • #12
                        Re: Crashing!!

                        As mentioned in a previous post, we are aware of these problems and have already addressed them in the code internally. Thanks to all of you who took the time to point out the problems you were having. We should have a new service release out this week that will address these occasional crashing issues.