Andromo - Start Making Apps - Free Signup

Announcement

Collapse
No announcement yet.

Greek and Japanese Fonts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Greek and Japanese Fonts

    Hi,

    I am currently working with the trial version of AutoPlay Media Studio5 and would like to purchase the software. However, I am having difficulty displaying Greek characters.

    I have tried using both Arial and Arial(Unicode) ttf fonts but with no success. To enter the text into a text box I copy the text from Word and paste it into the textbox but wind up with garbage text.

    Is it at all possible to display the fonts correctly?

    thanks for your help,
    pdeeney

  • #2
    Couple workarounds that might work for such characters:

    - display the text in a Web object
    - if the text doesn't need to change dynamically, display it in an image object (i.e. render the text into an image using Photoshop or some other paint program)
    --[[ Indigo Rose Software Developer ]]

    Comment


    • #3
      Hi Lorne,

      Thanks so much for your reply and help. The web object will do fine for paragraph text.

      Now I just need to find a way to do the same for buttons, labels and single line text. The web object doesn't seem to work due to the scroll bars.

      once again thanks for your help,
      pdeeney

      Comment


      • #4
        Okay, I've figured out a workaround that works well. I'm not sure if this method has been posted before. I've searched the forums and haven't found any reference so I figured I'd share my method with everyone.

        1) To display the text in then Greek fonts I first created a PDF file from the original document. (i.e. Word, CorelDraw, InDesign, Illustrator, etc.)

        2) Open the PDF and select the text I wish to place into AMS5

        3) In the font settings select the appropriate language under the Script combo box. (In my case Greek)

        Note: Although the font will still look like garbage int the Properties window. Once closed it will look correct in the display.

        Comment


        • #5
          Okay, I've figured out a workaround that works well. I'm not sure if this method has been posted before. I've searched the forums and haven't found any reference so I figured I'd share my method with everyone.

          1) To display the text in the Greek fonts I first created a PDF file from the original document. (i.e. Word, CorelDraw, InDesign, Illustrator, etc.)

          2) Open the PDF and select the text I wish to place into AMS5

          3) In the font settings select the appropriate language under the Script combo box. (In my case Greek)

          Note: Although the font will still look like garbage int the Properties window. Once closed it will look correct in the display.

          Comment


          • #6
            I am using hebrew fonts on a regular basis without any problems.
            I think you should check and see if your OS is localized. Not enough that Office is, Windows has to be localized too.
            Yossi

            Comment


            • #7
              I'm trying to do the same thing -- use Japanese fonts within button text. However, I can't seem to get them to show up properly on a Japanese system. Is there a certain font I should be using? Here's what I'm doing:

              I cut Japanese text from a Word document and paste it into the 'Text' section of the button Properties. I then changed the font to Arial Unicode MS and set the script to 'Japanese'. The sample text looks ok but when I click 'Ok', the button text still shows up as '???'. Just for kicks I tried launching the compiled autorun on a Japanese XP machine and the '???' were still showing up.

              Any thoughts/suggestions would be greatly appreciated. Thanks!

              Comment


              • #8
                Control Panel<Regional Options
                Under General TAB, check that Japanese is your Default language.
                Then, check under Input Locale TAB that Jpanese is your default input language.
                Hope that helps
                Yossi

                Comment


                • #9
                  Thanks for the reply, yossi. I did what you recommended and now I get an error from within the button's 'Property' window. Here's what I do: open the button's Property window and paste the Japanese text -- it shows up fine. It's using 'Verdana' as the default font which I'm pretty sure doesn't have any Japanese characters. If I switch it to one that does (such as MS UI Gothic) and change the 'Script' to Japanese, I get the following error when I click Ok:

                  “The font you have selected is either not a TrueType Font(TTF) or is registered in a non-standard manner: MS UI Gothic”

                  I went ahead and installed AutoPlay on a pure Japanese XP system and I'm getting the same error. Any thoughts?

                  Comment


                  • #10
                    Sorry Fender, but not really.
                    I would suggest you try and work with a unicode font like Arial Unicode. That could lessen the problem.
                    That's as far as I can go.
                    Good luck
                    Yossi

                    Comment


                    • #11
                      Thanks, Yossi. Unfortunately the error occurs on all of the fonts that would display Japanese characters. The basic fonts such as Verdana, Arial, and Times New Roman don't give me the error but of course they can't display Japanese characters.

                      I really think this error is the root of the problem. I've tried this on two different JP OSes so I don't think it's a font corruption thing. Hopefully IndigoRose tech support can figure out what's going on.

                      Thanks for you suggestions.

                      Comment


                      • #12
                        Using a Web Object

                        I have tried using a web object, which does seem to work fine, however there are side effects.

                        1. You cannot format the display of the web object. For some reason it has to be in a drop shadow box.
                        2. If you just wish to show a single word, scroll arrows are shown even when they are not required.

                        I have tried to use the image option so far however this is a very, very time consuming workaround if you have a large number of words enter.
                        Last edited by adcmtc; 12-20-2004, 03:42 AM.

                        Comment


                        • #13
                          Border in a web object is something that we have to live with (for the moment) as to the scroll bar, there is a variable (noscroll, I think) that you can use for not displaying the bar.
                          Yossi

                          Comment

                          Working...
                          X