No announcement yet.

Execute Regkey Error

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Execute Regkey Error

    I am using the execute command to run a regkey which i am installing to the program, I completed the execute as follows:

    "Full Path and filename of program"

    "Arguments to be passed on to the program"

    But it fails every time, whether i do it before or upon termination

    It says "can not import path\new.reg, There may be a disk or file system error"

    I have checked and the path is correct, i tried a .txt file with notepad.exe and it worked fine. Setup Factory Version 4.0

    Thanks Apoc


  • #2
    Re: Execute Regkey Error

    The error you're having sounds a bit strange. More information would be helpful, like the target OS platform SF is running on and the version format of the .reg file attempting to be merged. A version 5 exported .reg file cannot be merged into a version 4 registry. If it's not a version mismatch, maybe the IndigoRose guys have a better idea on wants going on.

    Also, you may want to try using the "Open Document" command on the .reg file instead of running regedit.exe explicitly. By opening the .reg file as a document the OS will automatically search the file associations and launch regedit with your .reg file.

    Oh... one other thing. Just a reminder that the Windows registry has security attributes associated with it that allow an administrator to lock down specified areas (usually HKLM) for non-previleged users. If you're installing without PowerUser or Admin previleges, then the .reg merge will fail if it is attempting to modify a locked down area. By locking down the registry and filesystem administrators can control the Install/Uninstall of software on workstations. This lock down feature is only enforced by Windows NT/2000.

    John L. Schacher
    [email protected]

    [This message has been edited by John Schacher (edited 11-01-2000).]