No announcement yet.

SUF 6.0 -

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • SUF 6.0 -

    1 - When the build proccess finish, the mouse pointer kept the clock icon.

    2 - When the uninstall proccess finish, the mouse pointer kept the clock icon.

    3 - If i try to change run-time install conditions or build-time include conditions for multiple files, my news conditions are deleted when i accept the multiple file properties windows. I can only set run-time and build-time conditions for one file at a time.

    4 - I have a problem installing one file, the DAO360.DLL library. With SUF5 proyects, all goes fine, but with SUF6 it gives me an error. This is the lines of the install log file about this file:

    Usage Count C:\Archivos de programa\Archivos comunes\Microsoft Shared\DAO\DAO360.DLL\DAO360.DLL, 2
    DLLRegisterServer C:\Archivos de programa\Archivos comunes\Microsoft Shared\DAO\DAO360.DLL\DAO360.DLL, Error de registro de ActiveX #_LOAD (1157)

  • #2
    Re: SUF 6.0 -


    1) This is only true until you move your Mouse. Plus the Status menu should queue you in that the build process has finished. Although thank you for the information this should be changed.

    2) The same as number one.

    3) When setting the conditions for Multiple Files make sure that you set the "Apply Method" (located on the Conditions Tab) to something other then: "None (Leave Existing Conditions". Did you do this? Does it still fail?

    4) Here is some information on the error code that you received. (Note: This is a Windows error code not a Setup Factory 6.0 error code)

    1157 "One of the library files needed to run this application cannot be found." - ERROR_DLL_NOT_FOUND

    Perhaps you are not installing or registering all the necessary files?

    MSI Factory The Next Generation Intelligent Setup Builder


    • #3
      Re: SUF 6.0 -

      3 - the Apply Method work right, no more problems now.

      4 - more info about the problem. When i Install my proyect with SUF6, it gives me an error with file DAO360.DLL "A decompresion error has been detected (#5) could not open output file)", this error only show if the target machine have this file previuosly installed (with or without SUF). If the target machine dont have this file, the installation work well. I had try with diferents conbinations of compress file/suppres "in-use" notice/protect but the problem always show.
      I had try too with various options of "if file already exists:", but the error always show.

      With the tool "scan dependencies", this library dont show any dependency file, except a few file that are in the negative file list.

      If posible that the problem is in my files, but i am wondering why this problem dont happend with SUF5 but allways show with SUF6.

      thanks for you support. This forums are wonderfull.


      • #4
        Re: SUF 6.0 -


        I have also been having trouble with installing dao360.dll. Further investigation shows that the variable %DAOPath% is storing the full filename & path to the systems DAO file i.e. C:\Program Files\Common Files\Microsoft Shared\DAO\dao360.dll

        I have worked around this by installing to %CommonFiles%\Microsoft Shared\DAO




        • #5
          Re: SUF 6.0 -

          you are right, the problem is the %DAOPath% variable.

          thanks Jez for the solution.
          a little question, \Microsoft Shared\DAO is allways a fixed path? can i be sure at 100% that in all machine the DAO path is %CommonFiles%\Microsoft Shared\DAO?
          Very much thanks in advance.


          • #6
            Re: SUF 6.0 -


            I've never seen a product (from MS) where the user can change the install path for DAO, and because the %CommonFiles% is under %ProgramFiles% it does get around the biggest problem of different language versions of Windows different names for Program Files i.e. "Archivos de programa" or "Programas".

            I'm pretty certain that once you're in the Common Files folder in any language, the Microsoft folder names are in English. I can't say that it'll work 100% of the time but it'll do until there is a fix!!


            [This message has been edited by Jez (edited 11-22-2001).]


            • #7
              Re: SUF 6.0 -

              We have fixed that for the next release. We were leaving the DAO*.DLL on the end by mistake. For now you could always pass %DAOPath% through a Parse Path action if you detect that the last four characters are ".DLL".

              - Brett