No announcement yet.

SF6.0.1.2: Problem with installing TTF font

  • Filter
  • Time
  • Show
Clear All
new posts

  • SF6.0.1.2: Problem with installing TTF font


    I want to install a TTF font to %FontDir%. The option "Register as TrueType font" is checked, but the fontfile was only copied to %FontDir% and does not get registered.

    Can someone tell me, what's going wrong?

    Thanks in advance!

  • #2
    Re: SF6.0.1.2: Problem with installing TTF font

    I have a few questions for you:

    1) What OS are you installing on?
    2) If it is an NT based OS, are you logged in with administrative permissions?
    3) Have you checked the Registry to see what is in the Registry after the install?
    4) What if you reboot the system, is it available at that point?
    5) Have you created an installation log file with your install? What information is written to it concerning the registration?
    6) Are you able to install the font manually on that system outside of Setup Factory?

    Hopefully with answers to some of these questions we can determine the cause.


    • #3
      Re: SF6.0.1.2: Problem with installing TTF font

      Hi Darryl

      I'm using Win2000 AdvServer and Win2000 Professional. Both with the same result. SF has been installed with admin (myself) rights. After installing, everything seemed ok, inclusive registry entries for fonts. I tried after rebooting, but without any change. When installing the font manually, functionality is ok.
      Maybe it would be a starting point for resolving the problem: the installed font is corrupt after running the setup! MS-Fontviewer shows an 'empty' file, means no test text appears (file length is ok). The original (backup) font before building the setup is shown ok. Tried the same procedure about 5 times.
      Logfile shows no abnormal behavior:

      [Installing from Archive]
      C:\Programme\FK-Client\FK_Client.exe (Installed)
      C:\WINNT\Fonts\BCode128.ttf (Installed) <-- thst's the font

      [Installing External]

      [Register Fonts]
      BarCode 128 INTERAL (TrueType), C:\WINNT\Fonts\BCode128.ttf
      Setup completed normally.

      Does SF6 explicitely 'open' the font file for reading, or does it only copy and register it anyway?

      (sorry for my bad english)


      • #4
        Re: SF6.0.1.2: Problem with installing TTF font

        I'm not aware of why that would occur, however if possible could you send that font file to [email protected] so I could take a look and test on my end?