Announcement

Collapse
No announcement yet.

Packages and "skipping"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Packages and "skipping"

    I'm developing a CD with roughly 1,200 discrete files on it. They are grouped into packages of about 70 to about 150 files each. When the user selects a package to install, the problem is that the install screen spends more time displaying "Skipping <filenames>" than it does displaying "Installing <filenames>"

    Is there any way to suppress the "skipping" message, or is it the penalty for this approach? (The alternative is creating a separate setup executable for what are now the various packages ... a route I'd prefer to avoid). A silent install is not viable with these packages - the user needs to select which to install.

    All ideas welcome.

  • #2
    Re: Packages and "skipping"

    There's currently no way to suppress the "Skipping" text for the files, however one option is to change the text that is displayed when it says "Skipping" if that helps you at all.

    All of the messages displayed are taken from the language module. So what you could do is go to Design->General Design, click the Languages tab. Then go into the properties for the language module(s) you currently have selected for inclusion. I believe the ID you want to look for is STAT_SKIP.

    You have two options here. You could change the message for the ID so it persists from that point on in your projects, or you could use an Assign Value action to assign a different string to the message ID STAT_SKIP somewhere before it is used.

    Hope that helps. I've submitted a suggestion for an alternate design concerning this issue.

    Comment

    Working...
    X