Announcement

Collapse
No announcement yet.

Delay between Screens - not showing anything to the impatient user

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Joerg
    replied
    Re: Delay between Screens - not showing anything to the impatient user

    Thx a lot for your response. Sorry for my delayed reply. But in fact of a vacation-day in germany i did't come to office until now.

    I'll try your suggestions.

    Thx again
    Joerg

    Leave a comment:


  • Darryl
    replied
    Re: Delay between Screens - not showing anything to the impatient user

    Hi,

    Try setting the following built-in variable. It may help in what you are trying to accomplish:

    %ShowFileCalcProgressDlg%
    This variable controls whether or not the Calculating File Information dialog is visible. If this variable is set to TRUE, the Calculating File Information Progress dialog will be visible. If it's set to FALSE, the Calculating File Progress dialog won't be visible.

    Also if you have large amounts of actions, you can also set this other variable:

    %ShowActionProgressDlg%
    This variable controls whether or not the Action Progress dialog is visible. If this variable is set to TRUE, the Action Progress dialog will be visible. If it's set to FALSE, the Action Progress dialog won't be visible.

    Note: This variable has no affect during the uninstall.

    Leave a comment:


  • Delay between Screens - not showing anything to the impatient user

    Hi Group,

    i have the following problem:

    i am managing a setup-package with my setup-factory 6.0.1.2 that has more than 4500 Files in.

    The building process works like a charm.

    But when the package is to be installed on the customers computer, there is a loooong delay after accepting the license screen and the following install-folder screen.

    On some machines there are more than 30 seconds delay in which the setup window is minimized (only a taskbar-icon is still there) and nothing happens on the screen. Nothing shows to the user that there is sth. going on.

    So many customers thought there was a crash or hang or sth. and contacted me for support and help.

    But they only were to impatient. Because after the delay, the setup continues without errors. This occurs on all computers. On faster machines the delay is shorter, on slower ones it goes up to a minute of delay.

    The same delay appears after the last "before-installing-screen" (the ready to install screen) and before the dialogwindow with the progress bar and the whirling filenames appears when the files are installed.

    1. Is there a way to avoid this delays (maybe it is the time to count the neccessary diskspace for installing before displaying the install folder screen and starting the installation/filecopy-process?)

    2. If it cannot be avoided. Is there a chance to display a "Please wait...still running" Splashscreen/Window, that the customer knows that there is sth. in progress and he had to be patient now?

    A MsgBox-Action is not really what i want because it will stop the installation process, waiting for the user to click on OK, and then the dialog still vanishes to nowhere for the long, long time and nothing is displayed to the user on the screen (only the little-no-ones-takes-attention-of button in the taskbar).

    The problem don't exist with my smaller projects with only a few hundred files in. So the amount of data seems to be concerned here, isn't it?

    Any hint appreciated.

    TIA
    Joerg
Working...
X