Announcement

Collapse
No announcement yet.

Deleting shortcuts doesn't work..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deleting shortcuts doesn't work..

    Hi

    I'm just finishing a quite complex patch. Everything works exept something that should be really simple - I want to delete some old shortcuts that aren't needed after the patch update.
    I've tried, due to me, all possible ways to get it to work. But it doesn't.

    I'm using winXP pro by the way...

    So;
    Example (that could be a part of a bigger project):
    1) Create a shortcut in the desktop
    2) Name it e.g. "TEST"
    3) Open the System Editors/Shortcuts icons.
    4a) Select "Remove s-cut"
    4b) Folder = %DeskTop%" (I also tried %DeskTopNT%)
    4c) Set s-cut description = "TEST"
    7) Compile...
    8) Run the patch
    NOTHING HAPPENS..the *** shortcut is still there..

    I've of course tried rebooting etc.

    What is the problem.


    //Mattias - Sweden

  • #2
    Mattias,

    I am sorry for the delayed response. I have tested this out and Visual Patch appears to remove shortcuts properly on my system.

    - Are you using the current version (1.0.0.3)?
    - What OS are you running?
    - Are you sure that there are no blank spaces either in the remove shortcut action or in the shortcut itself?

    Adam Kapilik

    Comment


    • #3
      Things works

      The problem was an extra space before the file description (stupid me).

      Remark/Idea for improvement:
      The reason that this problem occoured at all was that when I entered a version number in setup factory an extra space was entered (my misstake of course).

      But, I highly recommend that you check in the textboxes in setup factory if the is any space in the end of and entered figure or text (use a popup windows asking the user if he wants the space). In most cases this is a misstake of the user/developer. Now I have to live with this misstake until we make a new full version...

      //Mattias

      Comment

      Working...
      X