No announcement yet.

Installing Application using SCCM results in an error.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing Application using SCCM results in an error.

    I have a customer that is installing our software on Windows 10. Our software uses the latest version of Setup Factory. Our customer uses Microsoft's Software Center Configuration Manager (SCCM) to install our software using the Windows system account. During the install process, we display a setup screen for the user to select the location for user files. After the Next button is pressed, the install process hangs. Looking at Task Manager, the process irsetup.exe continues to run and accumulate system memory until it throws an error. Any idea what may be causing this?

    When installed outside of SCCM, everything works as expected and there is no issue.


  • #2
    This sounds like the System account cannot write to the path which was selected. User files most likely shouldn't be deployed by the elevated account or System, instead I believe that they could be copied to the common application data folder (typically C:\ProgramData), and on the first execution the application checks for the existence of the user files. If they already exist, use them. If they don't exist, copy them from ProgramData, already using the proper account (and security settings), and then use them.



    • #3
      I have a similar experience with a product called Dialux evo 7.1
      When installed as system user, the program fails with error code 5 (setup cancelled by user according to
      However when the same setup is run as user, but interactively (means it shows stuff in the current local session instead of session zero), it works.
      I'm currently stuck, as I can't figure out what causes the cancellation. I've checked every name not found and path not found error caused by the program using procmon and created the nessecary folders in the systemusers' profile. Some msi based installers fail when these don't exist when they construct their directory lists. This doesn't seem to fix the issue however.

      Is there a way to enable a log file, so we can see what is going on? Or is there a switch we need to use when using the system account like in ms sql perhaps?
      I've tried both /S and /S/W switches for install.

      I'm building deployment packages for SCCM as part of my job, and am using psexec from systemtools to test installers as if they were deployed with the SCCM client. This is done on a Windows 10 x64 enterprise system in an esx environment. The OS has no antivirus or other products installed, with the exception of an old version of Symantec's Wise package studio.
      I test on Win7 as well, but not until Win10 works - and we've not gotten there yet with this product.


      • #4
        Neiro - An installation log file can be generated for the install by going to Project > Log Files. There you can enable it and define it's location, filename, and error detail. If it ends up bombing out before the log file creation, it could be related to where the setup is trying to extract it's temporary files. In that case you could try using the /T command line option with a custom temporary directory as a test:

        ruthema - In addition to what Ulrich suggested, you may also want to generate an installation log file if you aren't currently. It's possible it will contain some further clues.


        • #5
          Ulrich: I confirmed with the customer that the hang occurs after the next button is pressed on screen that prompts the users for a location on where to install the user files. The only script that gets executed on the "On Next" action is the location selected by the user is captured in a session variable. The default location is the user's mydocuments or documents folder. That location is written to the registry at the very end of the install. In addition, user files are written to that location when setup factory begins the writing of files.

          I like your idea of using the ProgramData folder and will try that. This will solve several other related issues as well.

          Darryl: I have the logging turned on, but apparently Setup Factory doesn't get the chance to write it out just yet.

          Will post what I find.

          Thanks for your help!


          • #6
            So I have additional information on my issue now. The user returned a setup log file and the hang is occuring on the preload event for the screen where the user ius prompted on where to place the menu shortcuts.

            The pertinent data from the log file is:

            [10/10/2017 15:09:10] Success Display screen: Welcome to Setup
            [10/10/2017 15:09:11] Success Display screen: License Agreement
            [10/10/2017 15:09:12] Success Display screen: User Information
            [10/10/2017 15:09:12] Success Display screen: Verify Serial Number
            [10/10/2017 15:09:14] Success Display screen: Select Install Folder
            [10/10/2017 15:09:14] Success Display screen: Select User Files Folder
            [10/10/2017 15:09:15] Success Display screen: Select Shortcut Folder
            [10/10/2017 15:31:32] Error Script: Select Shortcut Folder > On Preload, Line 212 (1701)
            [10/10/2017 15:31:32] Error Script: Select Shortcut Folder > On Preload, Line 212 (1701)
            [10/10/2017 15:31:33] Error Script: Select Shortcut Folder > On Preload, Line 212 (1701)
            [10/10/2017 15:31:33] Error Script: Select Shortcut Folder > On Preload, Line 212 (1701)
            [10/10/2017 15:31:33] Error Script: Select Shortcut Folder > On Preload, Line 212 (1701)

            And this error is repeated until the setup process finally errors out.

            I have placed no additional code in the On Preload event for the "Select Shortcut Folder" screen.

            But the error number, 1701, description indicates that "Could not insert item into List Box control."

            Any idea why this might be occurring?



            • #7
              Ok, that information was helpful. In your Select Shortcut Folder's On Preload event you'll see that the global function g_FillComboBoxWithShortcutFolders is called there. The contents of that function can be viewed in the file \Setup Factory 9\Includes\Scripts\_SUF70_Global_Functions.lua. If the setup is being run under the system account, I was able to replicate the scenario using the instructions at the following URL which may be useful for testing:

              In a previous blog I explored two ways to launch a command prompt in Windows as the System user. Let's do it in Windows 10. Launch CMD as an administrator and navigate to the folder

              Now what I determined is that the session variable %StartProgramsFolder% returns blank when run under the system account since it doesn't have a profile which is the ultimate cause of the issue. So one possible way to handle that would be to check for that case, set a flag and make it a special case where you don't offer per-user versus all-user, but instead force it to use the all-user profile for the shortcut folder. For example:

              -- We only want to offer all user vs. per user on Windows NT 4.0/2000/XP+
              local bHideUserProfileOptions = false;
              local tblOS = System.GetOSVersionInfo();
              if(tblOS.PlatformId == "1")then
              bHideUserProfileOptions = true;

              bIsSystemAccount = false;
              strStartProgramsFolder = SessionVar.Expand("%StartProgramsFolder%");
              if (strStartProgramsFolder == "") then
              bIsSystemAccount = true;
              bHideUserProfileOptions = true;

              DlgRadioButton.SetProperties(CTRL_RADIOBTN_PERUSER ,{Visible = false});
              DlgRadioButton.SetProperties(CTRL_RADIOBTN_ALLUSER S,{Visible = false});
              -- Always use per user folders on Windows 95/98/ME
              if (bIsSystemAccount) then
              _UsePerUserFolders = false;
              _UsePerUserFolders = true;
              DlgRadioButton.SetProperties(CTRL_RADIOBTN_PERUSER ,{Checked = _UsePerUserFolders});
              DlgRadioButton.SetProperties(CTRL_RADIOBTN_ALLUSER S,{Checked = not _UsePerUserFolders});

              -- from _SUF70_Global_Functions.lua:
              -- fill the combo box with the existing shortcut folder names
              g_FillComboBoxWithShortcutFolders(CTRL_COMBOBOX_SH ORTCUTFOLDERS);


              • #8

                Your solution appears to have worked. I am waiting to hear from the end user, but the IT person said the install ran to completion.

                Thanks so much for your assistance!