Announcement

Collapse
No announcement yet.

/SILENT does not work in SUF 9.5.2.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • commhorizons
    replied
    Incidentally, I recommend that you allow either /S or /SILENT for Silent Mode.

    Leave a comment:


  • commhorizons
    replied
    You are right. I must have a logic error somewhere in my installer. Sorry for the false alarm.

    Leave a comment:


  • Ulrich
    replied
    It is working exactly as expected in my tests. I suggest that you create a new, empty installer, and place this at the beginning of the On Pre Install event script:

    Code:
    local sArgs = "";
    for i,v in pairs(_CommandLineArgs) do
        sArgs = sArgs .. v .. " ";
    end
    SetupData.WriteToLogFile("Info\tCommand line args: " .. sArgs .. "\r\n", true);
    SetupData.WriteToLogFile("Info\t_SilentInstall: " .. tostring(_SilentInstall) .. "\r\n", true);
    Here are the results when I executed setup.exe /S:

    Code:
    [08/16/2018 17:24:40] Notice    Start project event: On Startup
    [08/16/2018 17:24:40] Info    Command line args: C:\Users\ULRICH~1\AppData\Local\Temp\_ir_sf_temp_0\irsetup.exe /S __IRCT:3
    [08/16/2018 17:24:40] Info    _SilentInstall: true
    [08/16/2018 17:24:40] Success    Run project event: On Startup
    [08/16/2018 17:24:40] Success    Free space check on drive: C:\
    And here are the results when I executed setup.exe /SILENT:

    Code:
    [08/16/2018 17:25:06] Notice    Start project event: On Startup
    [08/16/2018 17:25:06] Info    Command line args: C:\Users\ULRICH~1\AppData\Local\Temp\_ir_sf_temp_0\irsetup.exe /SILENT __IRCT:3
    [08/16/2018 17:25:06] Info    _SilentInstall: false
    [08/16/2018 17:25:06] Success    Run project event: On Startup
    [08/16/2018 17:25:06] Success    Display screen: Welcome to Setup
    Everything performed as it should, no screens were shown during the first execution, while during the second run the screens were shown. Please perform this test and check the result.

    Ulrich

    Leave a comment:


  • commhorizons
    replied
    I rebuilt my installer (32-bit) using 9.5.2.0 and tried both /S and /SILENT. Neither one works. There appears to be a bug in 9.5.2.0. And yes, the box to Allow Silent/Unattended Install is checked.

    Leave a comment:


  • Ulrich
    replied
    Please note that the correct command line argument is /S, not /SILENT... There was an issue in previous releases, and any command line argument starting with /S would trigger silent install, and this could cause unexpected behavior. This is was corrected in version 9.5.2.0.

    Ulrich

    Leave a comment:


  • commhorizons
    started a topic /SILENT does not work in SUF 9.5.2.0

    /SILENT does not work in SUF 9.5.2.0

    I am using SUF 9.5.2.0 on Windows 10 x64. Under Advanced Project settings, "Enable silent/unattended install" is checked. However when I build and run the installer with parameter /SILENT it is still not running in Silent Mode. In the OnStartup Action section I even put debug output showing the value of _SilentInstall and it is false. Is this a known issue? Am I doing something wrong?
Working...
X