Announcement

Collapse
No announcement yet.

Silent Install does not deploy target files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Silent Install does not deploy target files

    Hi,

    I would like to ask help on my issue with my installation.

    There is an issue with my executable package when I do a silent install.

    Steps:
    1. At command line, ran the "MySetup.exe /S"
    2. Command completes OK, no error
    3. Logging works and displays my message that install was successful

    Issue:
    However, the files are not deployed. When I check the log files, I see that the target files to deploy are skipped due to "Conditions not met"

    Code:
    [04/02/2020 13:49:50] Skipped    Archive file: C:\config\OptionsFile.xml(Reason: Conditions not met)
    [04/02/2020 13:49:50] Skipped    Archive file: C:\config\ConfigFile.xml (Reason: Conditions not met)
    Do note that in my SetupFactory Project Settings > Advanced, the Enable silent/unattended install is checked.

    By the way, if i do the normal install, the target files are properly deployed. Only in silent install do I get the problem.

    Thank you for the help in advance!

  • #2
    Please attach the project file.

    Ulrich

    Comment


    • #3
      Hi Ulrich,

      Please see attached zipped project file.
      Attached Files

      Comment


      • #4
        Your error is that you placed these two files into a Package, but this package was not set to be deployed by default. You enabled the deployment with
        Code:
        SetupData.SetPackageProperties("PackageInstall", {Install=true});
        in the On Preload event script of the "Welcome to Setup" screen. Of course, as no screen is shown in a silent install, this code is never executed, so the Package is never flagged for deployment. This is wht you see the "condition is not met" for the installation of the files in the log file when running silently (without screens) and it works as expected when making an interactive install.

        Click image for larger version

Name:	SCRN-2020-04-06-01.png
Views:	206
Size:	7.6 KB
ID:	304930

        Ulrich

        Comment


        • #5
          Hi Ulrich,

          Thanks a lot for the help! So that's the problem right there. I did just as you advised, it works fine now. Thanks!

          Comment

          Working...
          X