Announcement

Collapse
No announcement yet.

ListBox screen is not displayed correctly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ListBox screen is not displayed correctly

    Hello,

    In some clients, List Box type screens are not displaying correctly (checks are seen as exclamation marks). The same thing happens with Radio Buttons.

    Thanks in advance


  • #2
    As a first test, I would turn off the custom fonts, rebuild the installer, and test it on the same target.
    If that resolves the issue, you may want to report the operating system version, language, and regional settings for non-Unicode programs are these clients using. Perhaps also the font name which you were using and was giving display problems.

    Ulrich

    Comment


    • #3

      Thank you for answering me. I do not use custom fonts, in the theme I use I have the '' Use Custom Font '' set to false

      Comment


      • #4

        The client's operating system is Czech and I have changed the language for non-unicode programs to Czech.

        Comment


        • #5
          Do you also have the custom font set to "false" in the screen? It could be the custom colors setting as well, please make sure it is set to default both in the theme and in the screen. Please set the language for non-Unicode programs to English, then try again.

          Ulrich

          Comment


          • #6
            Hello Ulrich,


            Thanks for answering. Use Custom Colors is enabled to configure screen colors. If I select English for non-Unicode programs the Czech texts will not be displayed.

            Comment


            • #7
              I am pretty sure that the text in Czech will be displayed properly as long as your strings are correctly ANSI encoded. I just ran an old demo project I did for AutoPlay Media Studio, showing that Czech letters can be shown perfectly.

              Click image for larger version

Name:	SCRN-2020-11-04-01.png
Views:	127
Size:	45.0 KB
ID:	305673

              You can have a white background in the interface if you use an image for the whole dialog. The use of custom colors changes the way Windows controls are drawn in the interface, and this is why I asked you to disable this setting, in order to determine if it eliminates the issue. Once the reason for the glitch is found, you can start to work around it.

              Ulrich

              Comment


              • #8
                Ok, I will try to see if it is solved. the weird thing is that it only happens on a couple of computers.

                Comment

                Working...
                X