Announcement

Collapse
No announcement yet.

Issue with the visibility of the radio buttons from the installer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue with the visibility of the radio buttons from the installer

    I have received an installer which contains radio buttons. Recently I noticed the installer is not displaying the radio buttons properly anymore. The issue seems to be isolated to my machine. Any clue what is happening? Below a screenshot of the installer involved:



    I have tried other installers (of which I knew they were working correctly) but they suffer from the same issue. I am running Windows 10 x64 Home Edition 21H1, latest updates applied.

  • #2
    This looks like your PC is unable to display some common controls for some reason. I have no idea why this might be happening, but perhaps a file system check could find something. Run "cmd.exe" as admin and execute this command:
    Code:
    sfc /scannow
    More details regarding this tool: https://support.microsoft.com/en-us/...3-966e85d4094e

    Ulrich

    Comment


    • #3
      Hi Ulrich, thanks for the reply. I followed the steps (I am familiar with sfc /scannow), but no issues were found... I also tried updating video card drivers, but that does not help either. Any more to think of?

      Comment


      • #4
        You are not using any kind of theme or skin in Windows 10, are you? If you are, I would try to turn it off and check if it makes a difference. Other than that, I have no idea.

        Ulrich

        Comment


        • #5
          Originally posted by Ulrich View Post
          You are not using any kind of theme or skin in Windows 10, are you? If you are, I would try to turn it off and check if it makes a difference. Other than that, I have no idea.

          Ulrich
          No, theme is standard, also tried other variations. Do not have a clue what has been changed recently. Which library is responsible for showing the radio button? Is that a Visual C++ runtime library or so?

          Comment


          • #6
            That would be the Common Controls library, which is part of Windows, as the setup is not using a custom skin, which could use its own bitmaps to draw the controls. https://docs.microsoft.com/en-us/win...ntrol-versions

            I contacted Gary from UK2000 Scenery, and built a setup using the same colors which he kindly provided, and Setup Factory 8 (which is no longer supported), but on my system I see the controls properly.

            Click image for larger version

Name:	SCRN-2021-09-16-01.png
Views:	16
Size:	84.3 KB
ID:	307593

            These other installers mentioned in your initial post, are they all built with Setup Factory?

            Ulrich

            Comment


            • #7
              Hi Ulrich, Gary provided me 2 test installers, and also with them I have the missing radio buttons. The screenshot above was also with an installer made with Setup Factory... Haven't found issues with other installers (yet). The mostly contain checkboxes which are displayed properly.

              Comment

              Working...
              X