Announcement

Collapse
No announcement yet.

Issue loading xml file.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue loading xml file.

    I have an issue with the xml.load command. My xml file contents are shown below. I have validated the xml data with a website and it checks out OK.

    I am using the following lua commands:

    local strRDDConfigFileAndPath = strUserFilesFolder .. "\\RDDConfig.xml"
    Dialog.Message("Parm check", strRDDConfigFileAndPath);
    XML.Load(strRDDConfigFileAndPath)

    The variable strUserFilesFolder is defined and I have validated the file path and name using the dialog.message line above.

    And I use the error checking as recommended by the Help file.
    The error occurs loading the xml file and the error number is 37000, which is not specific.

    Any idea what may be wrong or what I can do to further identify the error?

    Thanks,
    Mark

    <?xml version="1.0" encoding="utf-16" standalone="yes"?>
    <settings>
    <setting name="Case Folder" value="C:\Users\MAR\Documents\RadDecay 5\Cases" />
    <setting name="Library Folder" value="C:\Program Files (x86)\RadDecay 5\Library" />
    <setting name="Transform File" value="C:\Users\MAR\Documents\RadDecay 5\Styles\RDDDefault.xsl" />
    <setting name="Sort By Name" value="Yes" />
    <setting name="Use Curies" value="Yes" />
    <setting name="Selected Nuclide Library" value="3" />
    <setting name="Selected Back Color" value="-5374161" />
    <setting name="Selected Fore Color" value="-16777216" />
    <setting name="Not Ready Back Color" value="-65536" />
    <setting name="Not Ready Fore Color" value="-1" />
    <setting name="Generated Color" value="-5383962" />
    <setting name="Generated Fore Color" value="-16777216" />
    </settings>

  • #2
    You cannot load UTF-16 encoded files with Lua.

    Ulrich

    Comment

    Working...
    X